TelenetWiFree: Geldig IP, maar enkel telenet pingbaar

Forceflow
Starter
Starter
Berichten: 9
Lid geworden op: 20 Jan 2019
Uitgedeelde bedankjes: 2 keer

TelenetWiFree: Geldig IP, maar enkel telenet pingbaar

Berichtdoor Forceflow » 15 Jun 2019, 16:49

Zie ook: https://www.netweters.be/t5/WiFi/Wifree ... td-p/61244 (maar de layout van Netweters is een ramp voor me, dus ik vraag het liever hier)

Mijn main client is een Ubuntu machine, maar ik kan reproduceren op Android en op een Windows laptop.

De symptomen:
  • Instellingen: MSChapv2, PEAP, don't validate root cert. Authenticatie met username/pass werkt perfect. (99.99% zeker dat instellingen probleem niet zijn, maar hier is m'n config file voor de zekerheid)
  • Ik krijg steeds een geldig IP (10.127.X.X), binnen de paar seconden
  • Pingen naar telenet.be lukt, surfen naar telenet.be lukt ook (maar trraaagggg)
  • Pingen naar google.be (of een andere niet-telenet locatie) lukt niet. Pingen naar 8.8.8.8 ook niet, dus geen DNS probleem.
Ik krijg er geen consistentie in: soms werkt WiFree goed, en zolang ik verbinding niet te lang verlies (en IP dus ook niet) kan ik een dagje vrolijk surfen (speedtest OK, 20/2 telkens). Soms valt het weg, en kan ik met alle geklooi van de wereld geen IP meer krijgen waarmee ik het WWW op kan. :bang:

  • Het ligt niet aan mijn specifieke login - ik test op sommige momenten ook met de login van mijn ouders (totaal ander abbo in totaal andere stad), om te zien of dat een verschil maakt en mijn login mss ergens geblacklist staat ofzo. Zelfde wisselvallige resultaat.
  • Het ligt ook niet aan mijn specifieke apparaat. Op momenten dat het niet werkt kan ik met een Android telefoon, Windows laptop of eender welk ander apparaat hetzelfde probleem reproduceren. Ik kan wegens m'n technische achtergrond gewoon gemakkelijker diagnose stellen met m'n linux bakje :)
  • Ik dacht eerst dat het aan MAC address randomization zou liggen. In nieuwere OS'en scant je adapter telkens met een random MAC adres (voor security), en soms gebruikt ie ook telkens een ander MAC adres voor de effectieve verbinding (zie hier voor uitleg). MAC adres dus eens geforceerd op stabiel. Geen oplossing: soms werkt het, soms niet.
  • Er zijn hier verschillende TelenetWiFree access points in de buurt. Vanop mijn locatie zie ik er 3. Het maakt geen verschil met welke ik probeer te verbinden: ik kan de verbinding locken op 1 specifiek AP, of bij problemen wisselen van AP - probleem blijft.
  • Dan dacht ik: ok, sommige MAC adressen krijgen blijkbaar een IP dat wel toegang heeft tot WWW, en sommige een IP dat enkel toegang heeft tot telenet.be - wat manueel gespeeld met MAC adres lichtjes veranderen (basicly +1 tot ik een "goed" IP-krijg): ook hier krijg ik geen lijn in. Soms kan ik tot 3, 4 "goeie" IP's krijgen, en vanaf dan is het om zeep.

Nog mensen ervaringen? Ik denk dat ik ergens tegen een interne limiet van "toegelaten connecties" opboks. Waarom hij dan IP's blijft uitdelen is wel een raadsel, dat lijkt me alleen maar verwarring zaaien. Er zijn hier redelijk wat AP's in de buurt, maar ik woon in suburbia. Geen idee hoeveel apparaten hier aan het vechten zijn om op die AP's te kunnen.

CCatalyst
Elite Poster
Elite Poster
Berichten: 2151
Lid geworden op: 20 Jun 2016
Bedankt: 192 keer
Recent bedankt: 3 keer
Uitgedeelde bedankjes: 8 keer

Re: TelenetWiFree: Geldig IP, maar enkel telenet pingbaar

Berichtdoor CCatalyst » 17 Jun 2019, 22:07

Meer details nodig.

L1:
Welke Wi-Fi chipset, welke driver? Is driver up to date?
Herhaalt het probleem zich met externe adapter met antenne? Liefst een model met deftige chipset a la Atheros AR9271.
Hoe druk bezet is het kanaal waar je op werkt?
Hoe sterk is het signaal?
Bronnen van storing? Verlichting, microwave, Bluetooth, etc?

L2:
Forceflow schreef:Geen idee hoeveel apparaten hier aan het vechten zijn om op die AP's te kunnen.

Max is 4: https://userbase.be/forum/viewtopic.php?t=52841
Wi-Fi kaart in monitor mode zetten en met tcpdump kijken of er nog (te) veel verkeer op die BSSID werkt? Of met airmon-ng of WiFite oid.

L3:
"Ping lukt niet": timeout of een andere reden?
Traceroute naar telenet.be, waar situeert de latency zich?
Traceroute naar 8.8.8.8, waar eindigt het?

L4:
Doe een tcpdump op de wi-fi interface terwijl je naar http://www.telenet.be en http://www.google.be surft. Zie je fragmentation, resets, ... ?

Forceflow
Starter
Starter
Berichten: 9
Lid geworden op: 20 Jan 2019
Uitgedeelde bedankjes: 2 keer

Re: TelenetWiFree: Geldig IP, maar enkel telenet pingbaar

Berichtdoor Forceflow » 18 Jun 2019, 02:00

CCatalyst schreef:L1:
Welke Wi-Fi chipset, welke driver? Is driver up to date?
Herhaalt het probleem zich met externe adapter met antenne? Liefst een model met deftige chipset a la Atheros AR9271.
Hoe druk bezet is het kanaal waar je op werkt?
Hoe sterk is het signaal?
Bronnen van storing? Verlichting, microwave, Bluetooth, etc?

Verschillende apparaten dus: Laptopje gebaseerd op Raspi (Laatste Raspbian, alles up to date - de drivers die door Raspberry Pi Foundation zelf worden aangeleverd dus). Op grotere laptop (Dell XPS 15, Windows 10 - van het werk) en op Android telefoon (Android 9) zelfde probleem. Signaal is sterk genoeg, wavemon geeft link quality van 83% aan. Op momenten dat het werkt en ik dus een "werkend" IP krijg haal ik 20/2 op speedtest, het maximum van TelenetWiFree.

CCatalyst schreef:Max is 4: viewtopic.php?t=52841
Wi-Fi kaart in monitor mode zetten en met tcpdump kijken of er nog (te) veel verkeer op die BSSID werkt? Of met airmon-ng of WiFite oid.

Geen idee of die raspi in monitor mode kan - ik kijk er morgen naar.

CCatalyst schreef:"Ping lukt niet": timeout of een andere reden?
Traceroute naar telenet.be, waar situeert de latency zich?
Traceroute naar 8.8.8.8, waar eindigt het?

Is idd timeout. Ik vul info aan vanaf het terug kapot is - want nu werkt het weer :roll:


Terug naar “Telenet (Chello, UPC)”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 2 gasten